What’s Vulnerable › Vulnerabilities

CVE-2026-15723: Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when OmniAuth SAML and LDAP auto-linking were both enabled, an authenticated user could have taken over an existing LDAP-backed account without any interaction from the targeted user, due to improper input sanitization in the LDAP email lookup path used during OmniAuth identity linking.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-15723 or the next vulnerability affects your stack