What’s Vulnerable › Vulnerabilities
CVE-2026-15792: Possible panic when incorrect parameters sent from frontend
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-20
Description
A malicious BuildKit client or frontend could craft a request that could lead to BuildKit daemon crashing with a panic.
Affected products
- moby BuildKit: before 0.31.2 — fixed in 0.31.2
How to fix
Upgrade to a fixed version: moby BuildKit 0.31.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15792 or the next vulnerability affects your stack