What’s Vulnerable › Vulnerabilities
CVE-2026-15810: Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Affected products
- Google Cloud Looker: before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36 — fixed in 25.12.65, 25.18.68, 25.6.103, 26.0.66, 26.2.47, 26.4.36
How to fix
Upgrade to a fixed version: Google Cloud Looker 25.12.65, 25.18.68, 25.6.103, 26.0.66. Check the vendor advisory for mitigations.
References
- https://docs.cloud.google.com/looker/docs/release-notes#July_22_2026
- https://docs.cloud.google.com/support/bulletins#gcp-2026-049
Get alerted when CVE-2026-15810 or the next vulnerability affects your stack