What’s Vulnerable › Vulnerabilities

CVE-2026-15830: Potential denial-of-service vulnerability via nested geometry collections

Description

An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18. GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 5.2.17, 6.0.8; Pypi Django 5.2.17, 6.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-15830 or the next vulnerability affects your stack