What’s Vulnerable › Vulnerabilities

CVE-2026-15831: Generation of Incorrect Security Tokens in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.1.3 and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user to bypass administrator-configured tool governance policies due to improper authorization enforcement during token generation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-15831 or the next vulnerability affects your stack