What’s Vulnerable › Vulnerabilities
CVE-2026-15895: OS command injection in jsii-diff in AWS jsii
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-78
Description
OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument. To mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.
Affected products
- AWS jsii: before 1.131.0 — fixed in 1.131.0
How to fix
Upgrade to a fixed version: AWS jsii 1.131.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-057-aws/
- https://github.com/aws/jsii/releases/tag/v1.131.0
Get alerted when CVE-2026-15895 or the next vulnerability affects your stack