What’s Vulnerable › Vulnerabilities
CVE-2026-15917: Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-011
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-08-28
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 11.3.0 to 11.3.14, from 11.4.0 to 11.4.4, from 0.0.0 to 11.2.*.
Affected products
- Drupal: from 11.3.0 before 11.3.14; from 11.4.0 before 11.4.4; 11.2.x — fixed in 11.3.14, 11.4.4
How to fix
Upgrade to a fixed version: Drupal 11.3.14, 11.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15917 or the next vulnerability affects your stack