What’s Vulnerable › Vulnerabilities
CVE-2026-15939: Simple Restrict < 1.2.9 - Contributor+ Restricted Content Disclosure via REST API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-02 · updated 2026-08-26
- Weakness: CWE-863
Description
The Simple Restrict WordPress plugin before 1.2.9 does not enforce its content-restriction permission check on the REST API the way it does on the front end, relying there on a generic capability check instead of the Simple Restrict WordPress plugin before 1.2.9's own permission system, allowing users with contributor-level access or above to read the content of restricted posts and pages they were never granted access to.
Affected products
- Simple Restrict: before 1.2.9 — fixed in 1.2.9
How to fix
Upgrade to a fixed version: Simple Restrict 1.2.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15939 or the next vulnerability affects your stack