What’s Vulnerable › Vulnerabilities
CVE-2026-15996: Denial of service vulnerability in GitHub Enterprise Server allowed unauthenticated service disruption via deeply nested request parameters
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-23
- Weakness: CWE-674
Description
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause excessive CPU consumption and exhaust the pool of request-handling worker processes by sending a crafted form-encoded HTTP POST request containing deeply nested parameters. Because request parameters were parsed before routing and authentication, any POST endpoint could be used to trigger the condition, which could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, and 3.17.16.
Affected products
- GitHub Enterprise Server: before 3.17.16; from 3.18.0 before 3.18.10; from 3.19.0 before 3.19.7; from 3.20.0 before 3.20.3 — fixed in 3.17.16, 3.18.10, 3.19.7, 3.20.3
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.17.16, 3.18.10, 3.19.7, 3.20.3. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.16
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.10
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.7
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.3
Get alerted when CVE-2026-15996 or the next vulnerability affects your stack