What’s Vulnerable › Vulnerabilities
CVE-2026-16022: Command Injection in @oblique/cli
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-23
- Weakness: CWE-78
Description
@oblique/cli 15.4.0 contains an OS command injection vulnerability in the project creation functionality. The CLI constructs shell commands through string concatenation and executes them with execSync(). A user-controlled project-name argument is inserted into the shell command without proper neutralization, allowing shell metacharacters to execute additional operating-system commands when the CLI is invoked with a crafted project name.
Affected products
- Swiss Federal Office of Information Technology, Systems and Telecommunication @oblique/cli: from 15.4.0 before 15.4.2 — fixed in 15.4.2
How to fix
Upgrade to a fixed version: Swiss Federal Office of Information Technology, Systems and Telecommunication @oblique/cli 15.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16022 or the next vulnerability affects your stack