What’s Vulnerable › Vulnerabilities

CVE-2026-16044: Insufficient validation of guest board admin privileges on archive import

Description

Mattermost versions 11.7.x <= 11.7.6, 10.11.x <= 10.11.21 fail to prevent guest users from receiving Board Admin privileges during board archive import which allows a board member to escalate a guest user to Board Admin via importing a crafted .boardarchive file. Mattermost Advisory ID: MMSA-2026-00672

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.22, 11.7.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-16044 or the next vulnerability affects your stack