What’s Vulnerable › Vulnerabilities
CVE-2026-16058: YayCurrency < 3.3.5 - Unauthenticated Order and Vendor Financial Data Disclosure via Dokan Integration
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-22
- Weakness: CWE-639
Description
The YayCurrency WordPress plugin before 3.3.5 does not perform any capability or ownership check on several of its multi-vendor integration handlers that are reachable by unauthenticated users, allowing anyone to read the store's order totals and its vendors' earnings, balance ledgers, and withdrawal histories by iterating identifiers.
Affected products
- YayCurrency: before 3.3.5 — fixed in 3.3.5
How to fix
Upgrade to a fixed version: YayCurrency 3.3.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16058 or the next vulnerability affects your stack