What’s Vulnerable › Vulnerabilities

CVE-2026-1606: Improper Control of Generation of Code ('Code Injection') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 14.8 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user to conceal content within a Snippet due to improper input validation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1606 or the next vulnerability affects your stack