What’s Vulnerable › Vulnerabilities
CVE-2026-16065: Welcart e-Commerce < 2.11.32 - Editor+ SQL Injection via CSV Import
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-89
Description
The Welcart e-Commerce WordPress plugin before 2.11.32 does not properly sanitise a value taken from an imported CSV file before using it in a SQL statement, allowing users with the Editor role and above (including its custom shop-management roles) to perform SQL injection attacks.
Affected products
- Welcart e-Commerce: before 2.11.32 — fixed in 2.11.32
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.11.32. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16065 or the next vulnerability affects your stack