What’s Vulnerable › Vulnerabilities
CVE-2026-16066: Welcart e-Commerce < 2.11.34 - Author+ Stored XSS via Product Name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-79
Description
The Welcart e-Commerce WordPress plugin before 2.11.34 does not sanitise or escape a product field before outputting it on the product pages, allowing users with the Author role and above to inject arbitrary web scripts that execute in the browser of any visitor viewing the product page.
Affected products
- Welcart e-Commerce: before 2.11.34 — fixed in 2.11.34
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.11.34. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16066 or the next vulnerability affects your stack