What’s Vulnerable › Vulnerabilities

CVE-2026-16111: IBM DataPower Gateway Type Confusion

Description

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow an attacker to cause a denial of service due to a type confusion flaw.

Affected products

How to fix

Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.23, 10.6.0.11, 11.0.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-16111 or the next vulnerability affects your stack