What’s Vulnerable › Vulnerabilities
CVE-2026-1615
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-09 · updated 2026-08-25
- Weakness: CWE-94
Description
Versions of the package jsonpath before 1.3.0 are vulnerable to Arbitrary Code Injection via unsafe evaluation of user-supplied JSON Path expressions. The library relies on the static-eval module to process JSON Path input, which is not designed to handle untrusted data safely. An attacker can exploit this vulnerability by supplying a malicious JSON Path expression that, when evaluated, executes arbitrary JavaScript code, leading to Remote Code Execution in Node.js environments or Cross-site Scripting (XSS) in browser contexts. This affects all methods that evaluate JSON Paths against objects, including .query, .nodes, .paths, .value, .parent, and .apply.
Affected products
- jsonpath: before 1.3.0 — fixed in 1.3.0
- org.webjars.npm:jsonpath: all versions
How to fix
Upgrade to a fixed version: jsonpath 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/dchester/jsonpath/blob/c1dd8ec74034fb0375233abb5fdbec51ac317b4b/lib/handlers.js%23L243
- https://github.com/dchester/jsonpath/commit/b61111f07ac1a8d0f3133b5fc51438ecb76a6c39
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-15141219
- https://security.snyk.io/vuln/SNYK-JS-JSONPATH-13645034
- https://access.redhat.com/errata/RHSA-2026:59155
- https://access.redhat.com/errata/RHSA-2026:6308
- https://access.redhat.com/errata/RHSA-2026:6309
- https://access.redhat.com/errata/RHSA-2026:6802
- https://access.redhat.com/security/cve/CVE-2026-1615
- https://bugzilla.redhat.com/show_bug.cgi?id=2437875
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-1615.json
Get alerted when CVE-2026-1615 or the next vulnerability affects your stack