What’s Vulnerable › Vulnerabilities
CVE-2026-16238: PostgreSQL type confusion in pg_restore_attribute_stats() executes arbitrary code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-843
Description
Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.
Affected products
- PostgreSQL: from 14.0 before 14.24; from 15.0 before 15.19; from 16.0 before 16.15; from 17.0 before 17.11; from 18.0 before 18.5 — fixed in 14.24, 15.19, 16.15, 17.11, 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16238 or the next vulnerability affects your stack