What’s Vulnerable › Vulnerabilities

CVE-2026-16255: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 12.0 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when the instance-wide SAML or LDAP membership lock was enabled, an authenticated user could have granted or accepted project and group membership outside the identity provider's control, due to incomplete enforcement of the membership lock on requests created before the lock was enabled.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-16255 or the next vulnerability affects your stack