What’s Vulnerable › Vulnerabilities
CVE-2026-16258: Ajax Search Lite < 4.14.5 - Unauthenticated PHP Object Injection via Search Statistics REST Endpoint
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-08-26
- Weakness: CWE-502
Description
The Ajax Search Lite WordPress plugin before 4.14.5 does not prevent the deserialization of untrusted input, allowing unauthenticated attackers to perform PHP Object Injection. When a suitable POP chain is present via another installed Ajax Search Lite WordPress plugin before 4.14.5 or , this can be leveraged to achieve Remote Code Execution.
Affected products
- Ajax Search Lite: before 4.14.5 — fixed in 4.14.5
How to fix
Upgrade to a fixed version: Ajax Search Lite 4.14.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16258 or the next vulnerability affects your stack