What’s Vulnerable › Vulnerabilities
CVE-2026-16268: Newsletters < 4.16 - Unauthenticated Server-Side Request Forgery via SNS Bounce Handler
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-918
Description
The Newsletters WordPress plugin before 4.16 does not authenticate or validate a bounce-processing request before fetching a user-supplied URL on the server side, allowing unauthenticated attackers to make the site issue requests to arbitrary internal or external hosts.
Affected products
- contrid Newsletters: before 4.16 — fixed in 4.16
How to fix
Upgrade to a fixed version: contrid Newsletters 4.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16268 or the next vulnerability affects your stack