What’s Vulnerable › Vulnerabilities
CVE-2026-16269: Newsletters < 4.16 - Unauthenticated API Authentication Bypass via Type Juggling
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-08-26
- Weakness: CWE-287
Description
The Newsletters WordPress plugin before 4.16 does not strictly compare its API authentication key, allowing unauthenticated attackers to bypass the API authentication via type juggling and perform privileged actions such as modifying subscriber records and sending emails, when the optional API has been enabled.
Affected products
- contrid Newsletters: before 4.16 — fixed in 4.16
How to fix
Upgrade to a fixed version: contrid Newsletters 4.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16269 or the next vulnerability affects your stack