What’s Vulnerable › Vulnerabilities
CVE-2026-16282: Appointment Hour Booking < 1.5.88 - Unauthenticated Booking Price Manipulation via tcost Parameter
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-08-26
- Weakness: CWE-287
Description
The Appointment Hour Booking WordPress plugin before 1.5.88 does not validate a client-supplied booking price against the server-side configured service price, allowing unauthenticated users to submit an arbitrary final price (including zero or negative) that is stored as the authoritative booking price, corrupting booking and payment records.
Affected products
- Appointment Hour Booking: before 1.5.88 — fixed in 1.5.88
How to fix
Upgrade to a fixed version: Appointment Hour Booking 1.5.88. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16282 or the next vulnerability affects your stack