What’s Vulnerable › Vulnerabilities
CVE-2026-16294: Blubrry PowerPress < 11.17.1 - Contributor+ Server-Side Request Forgery via Podcast Episode Chapters URL
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-918
Description
The PowerPress Podcasting plugin by Blubrry WordPress plugin before 11.17.1 does not validate one of its Podcast Episode URL settings before performing a server-side request with it, allowing users with a role as low as Contributor to perform Server-Side Request Forgery attacks that can target internal services.
Affected products
- PowerPress Podcasting plugin by Blubrry: before 11.17.1 — fixed in 11.17.1
How to fix
Upgrade to a fixed version: PowerPress Podcasting plugin by Blubrry 11.17.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16294 or the next vulnerability affects your stack