What’s Vulnerable › Vulnerabilities
CVE-2026-16348: Command Injection Vulnerability in VPN connection of Archer BE800
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-78
Description
An authenticated command injection vulnerability in TP-Link Archer BE800 V1 allows an attacker with administrative access to execute arbitrary system commands with root privileges by injecting shell metacharacters via a VPN connection. Successful exploitation may enable persistent backdoors, credential theft, LAN reconnaissance, and router-assisted attacks against connected devices.
Affected products
- TP-Link Systems Inc. Archer BE800 v1: before 1.4.2 Build 260708 — fixed in 1.4.2 Build 260708
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer BE800 v1 1.4.2 Build 260708. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-be800/v1/#Firmware
- https://www.tp-link.com/us/support/download/archer-be800/v1/#Firmware
- https://www.tp-link.com/us/support/faq/5264/
Get alerted when CVE-2026-16348 or the next vulnerability affects your stack