What’s Vulnerable › Vulnerabilities
CVE-2026-1642: NGINX vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-349
Description
A vulnerability exists in NGINX OSS and NGINX Plus when configured to proxy to upstream Transport Layer Security (TLS) servers. An attacker with a man-in-the-middle (MITM) position on the upstream server side—along with conditions beyond the attacker's control—may be able to inject plain text data into the response from an upstream proxied server. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.2.0 through 1.6.2; from 2.0.0 before 2.4.1 — fixed in 2.4.1
- F5 NGINX Ingress Controller: from 3.4.0 through 3.7.2; from 4.0.0 through 4.0.1; from 5.0.0 before 5.3.3 — fixed in 5.3.3
- F5 NGINX Instance Manager: from 2.15.1 through 2.21.0
- F5 NGINX Open Source: from 1.3.0 before 1.28.2; from 1.29.0 before 1.29.5 — fixed in 1.28.2, 1.29.5
- F5 NGINX Plus: from r33 before r35; r32, r32-p1, r32-p2, r32-p3, r33-p1, r33-p2 (+6) — fixed in r35
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.4.1; F5 NGINX Ingress Controller 5.3.3; F5 NGINX Open Source 1.28.2, 1.29.5; F5 NGINX Plus r35. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000159824
- http://www.openwall.com/lists/oss-security/2026/02/05/1
Get alerted when CVE-2026-1642 or the next vulnerability affects your stack