What’s Vulnerable › Vulnerabilities
CVE-2026-16440
- Severity: medium (CVSS 5.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-22
- Weakness: CWE-674
Description
In Eclipse OpenJ9 versions up to 0.60, a crafted .class file with deeply nested annotations causes a segmentation fault.
Affected products
- The Eclipse Foundation Eclipse OpenJ9: from 0.8.0 before 0.60 — fixed in 0.60
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.60. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-openj9/openj9/pull/24572
- https://github.com/eclipse-openj9/openj9/security/advisories/GHSA-ch6r-v7rg-4jqx
- https://github.com/eclipse-openj9/openj9/security/advisories/GHSA-ch6r-v7rg-4jqx
Get alerted when CVE-2026-16440 or the next vulnerability affects your stack