What’s Vulnerable › Vulnerabilities
CVE-2026-16538: TeraWallet - Wallet for WooCommerce < 1.6.10 - Subscriber+ Wallet Balance Inflation via Discounted Top-Up
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-284
Description
The Wallet for WooCommerce WordPress plugin before 1.6.10 does not verify the amount actually collected for a wallet top-up before crediting the wallet, allowing customers to top up their wallet balance for less than its value.
Affected products
- Wallet for WooCommerce: before 1.6.10 — fixed in 1.6.10
How to fix
Upgrade to a fixed version: Wallet for WooCommerce 1.6.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16538 or the next vulnerability affects your stack