What’s Vulnerable › Vulnerabilities
CVE-2026-16540: Simply Schedule Appointments < 1.6.12.6 - Unauthenticated Appointment Data Disclosure and Mass Deletion via purge Endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-02 · updated 2026-08-26
- Weakness: CWE-863
Description
The Simply Schedule Appointments WordPress plugin before 1.6.12.6 does not correctly restrict a bulk appointment operation to the requester's own records, allowing unauthenticated users to retrieve the personal data of all appointments across the site and, on premium editions, to permanently delete them.
Affected products
- Simply Schedule Appointments: before 1.6.12.6 — fixed in 1.6.12.6
How to fix
Upgrade to a fixed version: Simply Schedule Appointments 1.6.12.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16540 or the next vulnerability affects your stack