What’s Vulnerable › Vulnerabilities

CVE-2026-16553: Insufficiently Protected Credentials in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed some sensitive information to be disclosed to an unintended host due to improper handling of upstream requests in virtual registries.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.5, 19.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-16553 or the next vulnerability affects your stack