What’s Vulnerable › Vulnerabilities
CVE-2026-16563: Academy LMS < 3.8.3 - Subscriber+ Arbitrary Lesson Content Disclosure via lessons REST Endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-08-26
- Weakness: CWE-284
Description
The Academy LMS WordPress plugin before 3.8.3 does not verify course enrollment or lesson publication status when returning a single lesson through its REST API, allowing users with a self-service student (Subscriber-level) account to disclose the content of arbitrary lessons, including lessons of paid courses they are not enrolled in and unpublished (draft, pending, private) lessons.
Affected products
- Academy LMS: before 3.8.3 — fixed in 3.8.3
How to fix
Upgrade to a fixed version: Academy LMS 3.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16563 or the next vulnerability affects your stack