What’s Vulnerable › Vulnerabilities
CVE-2026-16570: NextScripts: Social Networks Auto-Poster < 4.4.8 - Reflected XSS via Facebook OAuth Callback
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-22
- Weakness: CWE-79
Description
The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8 does not escape some of the query-string parameters it reflects back on one of its admin pages, allowing attackers to perform Reflected Cross-Site Scripting attacks against logged-in users such as administrators who are tricked into opening a crafted link.
Affected products
- NextScripts: Social Networks Auto-Poster: before 4.4.8 — fixed in 4.4.8
How to fix
Upgrade to a fixed version: NextScripts: Social Networks Auto-Poster 4.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16570 or the next vulnerability affects your stack