What’s Vulnerable › Vulnerabilities
CVE-2026-16584: AWS API MCP Server Security Policy Bypass via Startup Failure
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-455
Description
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
Affected products
- aws-api-mcp-server: from 0.2.13 before 1.3.47 — fixed in 1.3.47
How to fix
Upgrade to a fixed version: aws-api-mcp-server 1.3.47. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-063-aws/
- https://github.com/awslabs/mcp/security/advisories/GHSA-29w2-fq35-v728
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.47/
Get alerted when CVE-2026-16584 or the next vulnerability affects your stack