What’s Vulnerable › Vulnerabilities
CVE-2026-16589: WP Directory Kit < 1.5.5 - Subscriber+ SQL Injection via data_fields_list Parameter
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-08-26
- Weakness: CWE-89
Description
The WP Directory Kit WordPress plugin before 1.5.5 does not sanitize and escape a parameter before using it in a SQL statement through one of its authenticated AJAX actions, which lacks authorization and nonce checks, allowing any authenticated user such as a Subscriber to perform SQL injection attacks.
Affected products
- WP Directory Kit: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: WP Directory Kit 1.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16589 or the next vulnerability affects your stack