What’s Vulnerable › Vulnerabilities
CVE-2026-16591: WP Directory Kit < 1.5.8 - Listing Admin+ Stored XSS via Category and Location Title and Icon Fields
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-26
- Weakness: CWE-79
Description
The WP Directory Kit WordPress plugin before 1.5.8 does not sanitize and escape some of its category and location fields before outputting them in page attributes, allowing users with a WP Directory Kit WordPress plugin before 1.5.8-specific listing-management role (and without the unfiltered_html capability) to perform Stored Cross-Site Scripting attacks that execute for any visitor of the affected page.
Affected products
- WP Directory Kit: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: WP Directory Kit 1.5.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16591 or the next vulnerability affects your stack