What’s Vulnerable › Vulnerabilities
CVE-2026-16594: WP Directory Kit < 1.5.5 - Subscriber+ Plugin Settings and API Key Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-08-26
- Weakness: CWE-200
Description
The WP Directory Kit WordPress plugin before 1.5.5 does not perform authorization or nonce checks on one of its authenticated AJAX actions, allowing any authenticated user such as a Subscriber to disclose the WP Directory Kit WordPress plugin before 1.5.5 settings including sensitive API keys and secrets.
Affected products
- WP Directory Kit: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: WP Directory Kit 1.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16594 or the next vulnerability affects your stack