What’s Vulnerable › Vulnerabilities
CVE-2026-16605: MultiVendorX < 5.0.11 - Store Owner+ Cross-Vendor Store Takeover and Deletion via Missing Authorization
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-08-26
- Weakness: CWE-862
Description
The MultiVendorX WordPress plugin before 5.0.11 does not verify that the store targeted through its REST API belongs to the requesting vendor, allowing an authenticated vendor (Store Owner and above) to view, take over, permanently delete, or modify any other vendor's store on the marketplace.
Affected products
- MultiVendorX: before 5.0.11 — fixed in 5.0.11
How to fix
Upgrade to a fixed version: MultiVendorX 5.0.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16605 or the next vulnerability affects your stack