What’s Vulnerable › Vulnerabilities
CVE-2026-16623: Create Block Theme < 2.10.0 - Admin+ PHP Code Injection via Pattern Save (Multisite)
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-08-26
- Weakness: CWE-94
Description
The Create Block WordPress plugin before 2.10.0 does not correctly escape user-supplied text before writing it into a generated PHP pattern file, allowing a multisite subsite administrator (who holds the capability gating this action but is denied the capability that normally gates PHP file editing) to inject and execute arbitrary PHP code on the server.
Affected products
- Create Block Theme: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: Create Block Theme 2.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16623 or the next vulnerability affects your stack