What’s Vulnerable › Vulnerabilities
CVE-2026-16627: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-19
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user with developer-role permissions to escalate privileges due to improper sanitization of HTML content rendered in a CI job modal.
Affected products
- GitLab: from 19.2.0 before 19.2.2 — fixed in 19.2.2
How to fix
Upgrade to a fixed version: GitLab 19.2.2. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-2-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/606678
- https://hackerone.com/reports/3880796
Get alerted when CVE-2026-16627 or the next vulnerability affects your stack