What’s Vulnerable › Vulnerabilities
CVE-2026-16634: TOML::XS versions before 0.06 for Perl bundle an unsupported and vulnerable version of tomlc99
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-1104
Description
TOML::XS versions before 0.06 for Perl bundle an unsupported and vulnerable version of tomlc99. The tomlc99 library is no longer maintained, and has an uncontrolled recursion vulnerability publicly reported in the issue tracker. Any caller that passes untrusted TOML to from_toml risks a stack overflow from a deeply-nested document. TOML::XS version 0.06 or later uses the successor tomlc17 library.
Affected products
- FELIPE TOML::XS: before 0.06 — fixed in 0.06
How to fix
Upgrade to a fixed version: FELIPE TOML::XS 0.06. Check the vendor advisory for mitigations.
References
- https://github.com/cktan/tomlc17
- https://github.com/cktan/tomlc99/issues/97
- https://metacpan.org/release/FELIPE/TOML-XS-0.06/changes
- https://raw.githubusercontent.com/cktan/tomlc99/29076dfd095bbbbd50a3c1b2760d29f4b83e74ac/README.md
- https://toml.io/en/v1.0.0
- http://www.openwall.com/lists/oss-security/2026/07/24/4
- https://github.com/cktan/tomlc99/issues/97
Get alerted when CVE-2026-16634 or the next vulnerability affects your stack