What’s Vulnerable › Vulnerabilities
CVE-2026-16640: Search API Autocomplete - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-082
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-08-28
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Search API Autocomplete allows Reflected XSS. This issue affects Search API Autocomplete versions: from 0.0.0 to 1.12.0.
Affected products
- Drupal Search API Autocomplete: before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: Drupal Search API Autocomplete 1.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16640 or the next vulnerability affects your stack