What’s Vulnerable › Vulnerabilities
CVE-2026-16728: undici vulnerable to downstream response desynchronization via retry interceptor
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-08-04
- Weakness: CWE-444
Description
undici's retry interceptor can deliver a response whose body length does not match the Content-Length header exposed to the application after a retry or resume of a partial response. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a malicious or faulty upstream can return a partial response with a mismatched framing header, close the socket early, and have the retry interceptor assemble a body of a different length while the original Content-Length stays attached. Applications that use the retry interceptor and forward upstream headers and bodies downstream, such as proxies or gateways, may then emit an invalid HTTP response with a stale Content-Length, leading to downstream response desynchronization, connection hangs, or response corruption. Exploitation requires the retry interceptor enabled, an upstream returning a mismatched partial response, and a downstream forwarder that does not remove or recalculate Content-Length. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.
Affected products
- undici: before 6.28.0; from 7.0.0 before 7.29.0; from 8.0.0 before 8.9.0 — fixed in 6.28.0, 7.29.0, 8.9.0
- Npm Undici: before 6.28.0; from 7.0.0 before 7.29.0; from 8.0.0 before 8.9.0 — fixed in 6.28.0, 7.29.0, 8.9.0
How to fix
Upgrade to a fixed version: undici 6.28.0, 7.29.0, 8.9.0; Npm Undici 6.28.0, 7.29.0, 8.9.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-8xcm-r25x-g524
Get alerted when CVE-2026-16728 or the next vulnerability affects your stack