What’s Vulnerable › Vulnerabilities
CVE-2026-16762: Denial-of-service vulnerability in the Qt Core QXmlStream parser (QXmlStreamReader) impacts Qt
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-407
Description
An attacker able to supply a crafted XML document to an application using QXmlStreamReader can cause disproportionate CPU consumption during parsing, making the application unresponsive (denial of service). Exploitation requires only that the application parse attacker-influenced XML; no authentication, privileges, or user interaction beyond ingesting the input are needed. There is no loss of confidentiality or integrity — no data disclosure, data modification, or code execution — and the impact is contained to the affected process.
Affected products
- Qt: from 4.3.0 before 6.8.9; from 6.9.0 before 6.11.2 — fixed in 6.11.2, 6.8.9
How to fix
Upgrade to a fixed version: Qt 6.11.2, 6.8.9. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/738885
- https://codereview.qt-project.org/c/qt/qtbase/+/738901
- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-16762:
Get alerted when CVE-2026-16762 or the next vulnerability affects your stack