What’s Vulnerable › Vulnerabilities
CVE-2026-16870: Multiple Security Vulnerabilities in Snowflake libsnowflakeclient
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-07-30
- Weakness: CWE-121
Description
Multiple security vulnerabilities in Snowflake libsnowflakeclient versions prior to 2.9.2 could allow remote code execution and credential exfiltration. A stack-based buffer overflow in the file download path could allow remote code execution on a victim host. An attacker could exploit this by uploading a file with a crafted encryption metadata field to a shared internal stage that a victim process later downloads, and impact would be limited to deployments where principals with different privilege levels share the same internal stage. A related out-of-bounds write in the same download path could allow memory corruption with attacker-controlled write primitives. An attacker may exploit this through a crafted initialization vector metadata field on a shared stage, and impact would be limited by the same stage-write precondition. Improper validation of connection parameters could allow an attacker-controlled input to redirect outbound authentication requests — including credentials and tokens — to an attacker-controlled endpoint. Impact is limited to embedding deployments where a lower-privileged principal can influence connection configuration while higher-privileged service credentials are in use. The fix is available in Snowflake libsnowflakeclient version 2.9.2. The Snowflake PHP PDO Driver and Snowflake ODBC Driver embed the affected library; fixes are available in versions 4.1.0 and 3.19.0 respectively. Users must manually upgrade.
Affected products
- Snowflake libsnowflakeclient: before 2.9.2 — fixed in 2.9.2
- Snowflake ODBC Driver: from 2.16.3 before 3.19.0 — fixed in 3.19.0
- Snowflake PHP PDO Driver: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Snowflake libsnowflakeclient 2.9.2; Snowflake ODBC Driver 3.19.0; Snowflake PHP PDO Driver 4.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16870 or the next vulnerability affects your stack