What’s Vulnerable › Vulnerabilities
CVE-2026-16940: Custom Fields for WooCommerce < 1.5.1 - Unauthenticated Arbitrary File Deletion via Path Traversal
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-08-26
- Weakness: CWE-22
Description
The Custom Fields WordPress plugin before 1.5.1 does not validate a user-supplied file path before deletion, allowing unauthenticated users to delete arbitrary files on the server (such as wp-config.php), which can lead to a full site takeover.
Affected products
- Custom Fields: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Custom Fields 1.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16940 or the next vulnerability affects your stack