What’s Vulnerable › Vulnerabilities
CVE-2026-16949: Term Pages < 2.0.0 - Unauthenticated SQL Injection via tp_lookup
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-08-26
- Weakness: CWE-89
Description
The Term Pages WordPress plugin before 2.0.0 does not properly sanitise and escape a parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection attacks.
Affected products
- Term Pages: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Term Pages 2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16949 or the next vulnerability affects your stack