What’s Vulnerable › Vulnerabilities
CVE-2026-16954: AI Engine < 3.6.4 - Editor+ Sensitive Information Disclosure of API Key and Bearer Tokens
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-200
Description
The AI Engine WordPress plugin before 3.6.4 does not redact secret configuration values before exposing them in an admin page's inline script data, allowing users with the Editor role to read the site's stored third-party API key and authentication tokens in cleartext, despite those secrets being restricted to administrators everywhere else.
Affected products
- AI Engine: before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: AI Engine 3.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16954 or the next vulnerability affects your stack