What’s Vulnerable › Vulnerabilities
CVE-2026-16955: AI Engine < 3.6.6 - Subscriber+ Arbitrary File Read via Audio Transcription
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-08-26
- Weakness: CWE-22
Description
The AI Engine WordPress plugin before 3.6.6 does not confine a caller-supplied file path before reading it and forwarding the contents to an external service, allowing users with a subscriber-level account to read arbitrary files from the server and exfiltrate them off-host. Reaching the issue at subscriber level requires a non-default public API feature to be enabled; otherwise the same issue is reachable by an administrator, which on multisite allows a non-super subsite administrator to read the network-shared configuration and its secrets.
Affected products
- AI Engine: before 3.6.6 — fixed in 3.6.6
How to fix
Upgrade to a fixed version: AI Engine 3.6.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16955 or the next vulnerability affects your stack