What’s Vulnerable › Vulnerabilities
CVE-2026-16985: Squeeze < 1.7.12 - Author+ Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-08-26
- Weakness: CWE-434
Description
The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the upload_files capability (Author and above) to write an executable PHP file into the uploads directory and achieve remote code execution.
Affected products
- Squeeze: before 1.7.12 — fixed in 1.7.12
How to fix
Upgrade to a fixed version: Squeeze 1.7.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-16985 or the next vulnerability affects your stack