What’s Vulnerable › Vulnerabilities
CVE-2026-17011: Nexter Blocks < 5.0.2 - Contributor+ Stored CSS Injection
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-09 · updated 2026-08-26
- Weakness: CWE-345
Description
The Nexter Blocks WordPress plugin before 5.0.2 does not restrict who can save global CSS through one of its REST endpoints, allowing users with at least the Contributor role to store arbitrary CSS that is rendered site-wide on the front end, enabling defacement, content hiding, and UI redressing.
Affected products
- Nexter Blocks: before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: Nexter Blocks 5.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17011 or the next vulnerability affects your stack